My Cubii Pro/Cubii Elite is not turning on when I pedal

If your Cubii Pro/Cubii Elite is not turning on when you pedal, please follow the below steps:

  1. Make sure that your Cubii battery is fully charged.  Plug your Cubii into an outlet using the provided adapter and charging cable.  The battery LED should blink. Charge until the LED turns green, to indicate fully charged (you can start using it when the light turns yellow).  You can continue using the Cubii while it's charging.

  2. Try resetting your Cubii Pro battery, as this will typically solve the charging issue: How To Reset or Replace your Cubii Pro Battery

  3. If the battery LED lights do not blink when you plug in the Cubii, the charging cord itself could be faulty.  If you have a standard micro USB cable around the house (a very common cord, used for Android phones, etc., see photo below for reference.)  Please try swapping out the cord to see if the Cubii will charge.

    mceclip0.png

  4. If the battery LED does not blink or the Cubii does not turn on, try charging your Cubii using a different outlet.

  5. If the above steps did not solve the issue, please contact support@mycubii.com for further assistance. Please provide the following information in the email.
    1. Your order number
    2. Serial Number, see picture below for where to find your Cubii's serial number.

      mceclip1.png
    3. Explanation of the issue
      • Have you followed the troubleshooting steps #1 through #4?
      • How long have you been using the Cubii?
      • When did this issue start to occur? 
    4. Video recording (preferable)
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

0 comments

Article is closed for comments.